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Prerequisite: Scripting
Not going to cover for sake of time. There are a lot of good sources to learn it. Start with:

https://labviewwiki.org/wiki/VI_Scripting



Boring

Harmless / may be domesticated

Competent wizard should cope

Dangerous / requires specialist knowledge / 
skilled wizard may handle

Known wizard killer / impossible to train or 
domesticate

Classification of LabVIEW Hooks

X
XX
XXX
XXXX

XXXXX



All you need to know is where to put stuff, a few rules 
about naming conventions, and maybe include some 
extra text or image files.

Classification of LabVIEW Hooks

X



Knowledge of Scripting is a Prerequisite. Usually, the 
front door is a wizard of template to help guide you.

Classification of LabVIEW Hooks

XX



No template but maybe some examples. These can 
require you to replace shipped code. Just be careful to 
back things up.

Classification of LabVIEW Hooks

XXX



Buggy, limited documentation, or generally things not 
expected to be edited outside of NI.

Classification of LabVIEW Hooks

XXXX



Generally referred to as Rusty Nails. Enter at your own 
risk.

Classification of LabVIEW Hooks

XXXXX



1. Tools Menu

2. Help Menu

3. File Menu

4. User Library Palettes

5. New Dialog Templates

6. Quick Drop Keyboard Shortcuts

7. Right-Click Plugins

8. VI Analyzer Tests

9. Project Templates

10. Custom Probes

11. Quick Change Plugin (2023+)

12. New Class VIs

13. Edit->Create SubVI

14. Bookmark Manager

15. Icon Editor

16. Custom Channel Wires

17. Create\Edit Palettes

18. Navigation Window

19. XControls

20. New Dialog Wizards

21. Preference Pages

22. Property Pages

23. Project Providers

24. IDE Event Callback VIs

25. External Editors

26. XNodes

X
XX
XXX
XXXX
XXXXX



X



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\project\[subfolders optional]\[Main VI to Launch].vi
Put Support Code in Folder with underscore (“_”) prefix

• Activation: Click on Tools Menu -> [Optional Submenus] -> Item

• Uses: Wizards, Automate Code Generation and Inspection

• Example: So Many Shipped Examples

• Learn More: https://labviewwiki.org/wiki/How_to_do_Menu_Launch_VIs

Tools Menu X



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\help\[subfolders optional]\[Main VI to Launch].vi
Put Support Code in Folder with underscore (“_”) prefix

• Activation: Click on Help Menu -> [Optional Submenus] -> Item

• Uses: Open Help Documentation and About Dialogs

• Example: So Many Shipped Examples

• Learn More: https://labviewwiki.org/wiki/How_to_do_Menu_Launch_VIs

Help Menu X



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\wizard\[subfolders optional]\[Main VI to Launch].vi
Put Support Code in Folder with underscore (“_”) prefix

• Activation: Click on File Menu -> [Optional Submenus] -> Item

• Uses: Wizards

• Example: No Example, Folder Doesn’t Even Exist by Default

• Learn More: https://labviewwiki.org/wiki/How_to_do_Menu_Launch_VIs

File Menu X



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\user.lib\[optional subfolders]\[Your VIs]
Put Support Code in Folder with underscore (“_”) prefix

• Activation: 
• Block Diagram: Right-click for Palettes -> User Libraries

• Front Panel Right-click for Palettes -> User Controls
• See Your VIs or CTLs under your subfolder\palette

• Uses: Make it easier to find your library VIs, Adds VIs to Quick Drop

• Example: Not Many Examples, Might be some already installed

• Learn More: https://labviewwiki.org/wiki/Palette

User Library Palettes X



• Template: No Template

• Code Placement: 
• [LabVIEW 20xx]\templates\[your folder]\[All Your VIT Files]

• Folder Name (one per folder): [LabVIEW 20xx]\templates\[your folder].txt 

• Image: (one for each VIT file, 250x250px): [LabVIEW 20xx]\templates\[your folder]\[All Your VIT Files]*d.png

• Description: VI Description of the VIT

• Activation: 
Click on File Menu -> New… 
(See Your Templates under “From Template”)

• Uses: Template VIs, Creation of New VIs from a Template

• Example: So Many Shipped Examples

• Learn More: https://labviewwiki.org/wiki/How_to_do_Menu_Launch_VIs

New Dialog Templates X



XX



• Template: [LabVIEW 20xx]\resource\dialog\QuickDrop\QuickDrop Plugin Template.vit

• Code Placement: 
• All Users Per Version:[LabVIEW 20xx]\resource\dialog\QuickDrop\plugins

• Per User:[Documents]\LabVIEW Data\Quick Drop Plugins

• Activation:
• Assign Letter in Quick Drop

• Ctrl+Space, Ctrl+[Assigned Letter]

• Uses: Automate Code Generation and Inspection

• Example: Nattify, PaneRelief, Community List on the Forums

• Learn More: https://labviewwiki.org/wiki/Quick_Drop

Quick Drop Keyboard Shortcuts XX



• Template: [LabVIEW 20xx]\resource\plugins\PopupMenus\Create Shortcut Menu Plug-In From 
Template.vi

• Code Placement: 
• All Users Per Version: [LabVIEW 20xx]\resource\plugins\PopupMenus\edit time panel and 

diagram

• Per User:[Documents]\LabVIEW Data\PopupMenus\edit time panel and diagram

• Activation: Right-click on an item, specify item type/class in the code for the plugin

• Uses: Automate Code Generation and Inspection

• Example: So Many Shipped Examples, Community List on the Forums

• Learn More: https://labviewwiki.org/wiki/Shortcut_Menu_Plugins

Right-Click Menus XX



• Template: Tools Menu -> VI Analyzer -> Create New Test…

• Code Placement: 
Creates and LLB for all your code located at:
[Documents]\LabVIEW Data\VI Analyzer Tests

• Activation: 
Launch VI Analyzer from Tools Menu -> VI Analyzer -> Analyze VIs…
At the “Select Tests” step, make sure your test is selected

• Uses: Testing, Automate Code Inspection (and Editing)

• Example(s): Community List on the Forums

• Learn More: https://labviewwiki.org/wiki/VI_Analyzer

VI Analyzer Tests XX



• Template: 
• The MetaDataObj must be overridden. It is found in: 

[LabVIEW 20xx]\resource\dialog\NewProjectWizard\MetaDataObj\MetaDataObj.lvclass

• Scripting Code: [LabVIEW 20xx]\resource\dialog\NewProjectWizard\AfterPage2_Templates

• Specification Page: [LabVIEW 20xx]\resource\dialog\NewProjectWizard\SpecPage_Templates

• Code Placement: 
• XML Definition: [LabVIEW 20xx]\ProjectTemplates\MetaData

• Source: [LabVIEW 20xx]\ProjectTemplates\Source\[Subfolder]

• Activation: 
Getting Started Window -> Create Project
Any other Window, Project Menu -> Create Project…

• Uses: Automate Project Creation and Code Generation

• Example(s): Ships with some Examples

• Learn More: https://labviewwiki.org/wiki/Custom_Project_Template

Custom Project Templates XX



• Template: Right-click wire, select Custom Probe->New…

• Code Placement: 
• User Probes: [Documents]\LabVIEW Data\Probes

•  To make default for a particular data type: [LabVIEW 20xx]\user.lib\_probes\default

• Activation: Right-click wire and select Probe or Custom Probe

• Uses: Easier Visualization of Data for Debugging

• Example: Not Many Examples, Might be some already installed

• Learn More: https://labviewwiki.org/wiki/Custom_probe

Custom Probes XX



• Template: 
[LabVIEW 20xx]\resource\dialog\QuickChange\plugins\.prefix_Template
Instructions: [LabVIEW 
20xx]\resource\dialog\QuickChange\plugins\.prefix_Template\Instructions.txt

• Code Placement: 
[LabVIEW 20xx]\resource\dialog\ QuickChange \plugins\[Prefix_Folder]
Folders names beginning with a period '.' or underscore '_' will be skipped

• Activation: Ctrl+Space While Editing a Free Label

• Uses: Speed Up Code Generations

• Example: Ships with Examples

• Learn More: https://labviewwiki.org/wiki/Quick_Change

Quick Change Plugin (LV 2023+) XX



XXX



• Template: 
[LabVIEW 20xx]\resource\Framework\Providers\LVClassLibrary\CLSUIP_MemberTemplate.vit

• Code Placement: Edit the Template, Don’t change/add terminals

• Activation: Create Static/Dynamic Member VI

• Uses: Can Enforce Code Standards

• Example: Edit the Template

• Learn More: https://labviewwiki.org/wiki/LabVIEW_Class

New Class VIs: Member VI Template XXX



• Template: 
[LabVIEW 20xx]\resource\Framework\Providers\LVClassLibrary\NewAccessors\*.vit

• Code Placement: Edit the Template(s), Don’t change/add terminals

• Activation: Create Accessor VI

• Uses: Can Enforce Code Standards

• Example: Edit the Template

• Learn More: https://labviewwiki.org/wiki/LabVIEW_Class

New Class VIs: Accessor Templates XXX



• Template: [LabVIEW 
20xx]\resource\Framework\Providers\LVClassLibrary\NewAccessors\Custom User 
Scripting for *.vi

• Code Placement: Edit the SubVIs, Don’t change/add terminals

• Activation: Create Accessor VI

• Uses: Can Enforce Code Standards, Script Add/Remove of Other Elements

• Example: Edit the SubVI

• Learn More: https://labviewwiki.org/wiki/LabVIEW_Class

New Class VIs: Accessor Post Script XXX



• Template: 
[LabVIEW 20xx]\resource\Framework\Providers\LVClassLibrary\NewAccessors
CLSUIP_LocalizedStrings.vi

• Code Placement: Edit the Global VI, Don’t Rename the Controls

• Activation: Create Accessor VI

• Uses: Can Enforce Naming Conventions (Change Read/Write to Get/Set, etc.)

• Example: Edit the SubVI

• Learn More: https://labviewwiki.org/wiki/LabVIEW_Class

New Class VIs: Accessor Naming XXX



• Template: 
[LabVIEW 20xx]\resource\plugins\CreateSubVI\Additional Actions Template.vi

• Code Placement: Copy to:
[LabVIEW 20xx]\resource\plugins\CreateSubVI\CreateSubVI_AdditionalActions.vi

• Activation: 
• Select Code to Make SubVI
• Click on Edit Menu -> Create SubVI

• Uses: Script Clean-up code, etc.

• Example: The Current Code, Instructions in Code

• Learn More: https://labviewwiki.org/wiki/Create_SubVI

Extending Create SubVI XXX



• Template: 
[LabVIEW 20xx]\resource\plugins\lv_modifyNewSubVI.vi

• Code Placement: Edit the VI, Make sure to Create a Backup First

• Activation: 
• Select Code to Make SubVI

• Click on Edit Menu -> Create SubVI

• Uses: Create your own routine for creating a SubVI

• Example: The Current Code, Instructions in Code

• Learn More: https://labviewwiki.org/wiki/Create_SubVI

Replacing Create SubVI XXX



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\resource\dialog\BookmarkManager\managers\[your manager subfolder]
Change the Default.txt

• Activation: 
Click on View Menu -> Bookmark Manager
If more than one, prompts Select a Bookmark Manager

• Uses: Organizing and Displaying Bookmarks

• Example: Shipped with Default Bookmark Manager

• Learn More: https://labviewwiki.org/wiki/Custom_Bookmark_Manager

Custom Bookmark Manager XXX



• Template: 
Obtain the source code from the NI Forums, https://forums.ni.com/t5/Enhanced-Icon-Editor/bd-p/grp-1168

• Code Placement: 
• Rename [LabVIEW 20xx]\resource\plugins\lv_icon.lvlibp, the shipping icon editor, to lv_icon.lvlibp.ship to "hide" it.

• Archive [LabVIEW 20xx]\vi.lib\LabVIEW Icon API to preserve the shipping copy.  Use your archive program of choice (e.g. 
7-Zip).

• Copy the two directories provided (resource and vi.lib) into your [LabVIEW 20xx] directory.  This installs the code into 
[LabVIEW 20xx]\resource\plugins\lv_icon.vi with associated support files.

• Activation: Edit an Icon

• Uses: Change default or Add Functionality

• Example: Start with downloaded Icon Editor Source Code

• Learn More: https://labviewwiki.org/wiki/Custom_Icon_Editor

Custom Icon Editor XXX



• Template: [LabVIEW 20xx]\resource\Channels

• Code Placement: [LabVIEW 20xx]\resource\Channels\[New Subfolder]

• Activation: Right-Click a Terminal and Select the Custom Channel

• Uses: Extend Communication between Parallel Processes

• Example: Current Channels in the Channels Folder

• Learn More: 
https://labviewwiki.org/wiki/Custom_channel_wire

Custom Channel Wires XXX



• Template: 
Built-in Editor, Select Tools menu -> Advanced -> Edit Palette Set

• Code Placement: Editor Handles the Details

• Activation: Activate Palettes

• Uses: Make it easier to find your library VIs, Adds VIs to Quick Drop 

• Example: Built-in Editor

• Learn More: https://labviewwiki.org/wiki/Palette

Palette Creation: Editor XXX



• Template: [LabVIEW 20xx]\menus

• Code Placement: 
• Palette Files: [LabVIEW 20xx]\menus

• Activation: Activate Palettes

• Uses: Make it easier to find your library VIs, Adds VIs to Quick Drop 

• Example: Use API Functions to investigate structure of the Menus.

• Learn More: https://labviewwiki.org/wiki/Palette

Palette Creation: API XXX



• Template: No Template

• Code Placement:
Replace: [LabVIEW 20xx]\resource\dialog\zoom-out.llb
VI Peek add the necessary INI Hooks

• Activation: 
<Ctrl-Shift-N> OR Select View menu->Navigation Window

• Uses: Replace with more useful tools, like VI Peek

• Example: VI Peek

• Learn More: https://labviewwiki.org/wiki/Navigation_Window

Navigation Window XXX



XXXX



• Template: Select File menu->New…, then select XControl

• Code Placement: Wherever you want

• Activation: Drop and use on your VIs

• Uses: Custom UI Elements

• Example: 
Select the Help menu->Find Examples, the search for Xcontrol

• Learn More: https://labviewwiki.org/wiki/XControl

• NOTE: Use QControls instead. There is a lot of documentation why here:
https://labviewwiki.org/wiki/QControl

XControls XXXX



• Template: No Template

• Code Placement: [LabVIEW 20xx]\resource\plugins\[Your subfolder]
Edit the XML per LabVIEW Wiki’s Instructions
[LabVIEW 20xx]\resource\plugins\NewDialogFiles\LVNewDialog.xml

• Activation: 
Click on File Menu -> New…
The new item will appear in the Other Items category

• Uses: Adding Wizards to the New dialog

• Example: The QControl Toolkit

• Learn More: https://labviewwiki.org/wiki/New_dialog

New Dialog Wizards XXXX



• Template: 
[LabVIEW 20xx]\resource\dialog\PreferencesDialog\PreferencePages\pageTemplate.vit

• Code Placement: 
Override the PreferenceDialog.vi
[LabVIEW 20xx]\resource\dialog\PreferencesDialog\PreferenceDialog.vi
Create Your Page from the Template and Save it at:
[LabVIEW 20xx]\resource\dialog\PreferencesDialog\PreferencePages\User

• Activation: Select Tools menu->Options…

• Uses: Adding Custom Options to the LabVIEW Options dialog

• Example: There are pages that exists but are password protected.

• Learn More: https://labviewwiki.org/wiki/Options_dialog

Options Preference Pages XXXX



• Template: 
[LabVIEW 20xx]\resource\Framework\Providers\Builds\AppBuilder\AB_UI_Page_Info.vi

• Code Placement: 
Add your VI to the Framework_Initialize.vi
[LabVIEW 20xx]\vi.lib\AppBuilder\AB_Classes\[EXE, DLL, etc.]\Framework_Initialize.vi
Create Your Page from the Template and Save it at:
[LabVIEW 20xx]\resource\Framework\Providers\Builds\AppBuilder\

• Activation: Right-click on a Build Spec Tools ->Properties…

• Uses: Adding Custom Options to the LabVIEW Builds dialog

• Example: There are pages that exists but are password protected.

• Learn More: https://labviewwiki.org/wiki/Build_Specification_dialog

Build Spec Preference Pages XXXX



• Template: No Template, Does require certain inputs. Follow Wiki 
page.

• Code Placement: 
[LabVIEW 20xx]\resource\PropertyPages\Pages\PropPage_[your unique name].vi 

• Activation: Right-Click on an item -> Properties…

• Uses: Properties for Front Panel and Block Diagram Elements

• Example: Locked and Built-in, Good-Luck

• Learn More: https://labviewwiki.org/wiki/Properties_dialog

Property Pages XXXX



XXXXX



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\resource\plugins\lv_about.vi

• Activation: Select the Help menu -> About

• Uses: Override the About dialog

• Example: Overridden VIs

• Learn More: 
https://labviewwiki.org/wiki/Development_Environment_Event_Callback_VIs

IDE Event Callback VIs: lv_about.vi XXXXX



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\resource\plugins\lv_exit.vi

• Activation: Exit LabVIEW

• Uses: Interrupt LabVIEW from Exiting (0:Don't Exit; 1:Exit)

• Example: Overridden VIs

• Learn More: 
https://labviewwiki.org/wiki/Development_Environment_Event_Callback_VIs

IDE Event Callback VIs: lv_exit.vi XXXXX



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\vi.lib\lv_init.vi

• Activation: Start LabVIEW

• Uses: Executes at LabVIEW Start

• Example: Overridden VIs

• Learn More: 
https://labviewwiki.org/wiki/Development_Environment_Event_Callback_VIs

IDE Event Callback VIs: lv_init.vi XXXXX



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\resource\plugins\lv_login.vi

• Activation: Select Tools menu -> Security -> Login…

• Uses: Interrupt Login

• Example: No Example

• Learn More: 
https://labviewwiki.org/wiki/Development_Environment_Event_Callback_VIs

IDE Event Callback VIs: lv_login.vi XXXXX



• Template: No Template, Override VI

• Code Placement: 
[LabVIEW 20xx]\resource\plugins\lv_new.vi

• Activation: Select File menu -> New… 
OR New on the Getting Started Window

• Uses: Interrupt the launch of the New dialog

• Example: No Example

• Learn More: 
https://labviewwiki.org/wiki/Development_Environment_Event_Callback_VIs

IDE Event Callback VIs: lv_new.vi XXXXX



• Template: No Template, Override VI

• Code Placement: 
[LabVIEW 20xx]\resource\plugins\lv_new_vi.vi

• Activation: Select File menu -> New VI OR <Ctrl+N>

• Uses: Override the Create New VI to start with your on template

• Example: No Example

• Learn More: 
https://labviewwiki.org/wiki/Development_Environment_Event_Callback_VIs

IDE Event Callback VIs: lv_new_vi.vi XXXXX



• Template: No Template

• Code Placement: 
[LabVIEW 20xx]\resource\plugins\lv_open.vi

• Activation: Select the File menu -> Open OR <Ctrl+O>

• Uses: Interrupt the Open dialog, Create your own dialog.

• Example: No Example

• Learn More: 
https://labviewwiki.org/wiki/Development_Environment_Event_Callback_VIs

IDE Event Callback VIs: lv_open.vi XXXXX



• Template: No Template, Sparse Documentation

• Code Placement: 
[LabVIEW 20xx]\resource\framework\providers\

• Activation: Depends on the Project Provider

• Uses: Adding to the Project Explorer Window

• Example: Downloadable Examples

• Learn More: 
https://labviewwiki.org/wiki/Project_Provider_Framework

Project Providers XXXXX



• Template: No Template, Sparse Documentation

• Code Placement: Pretty much anywhere
Get Hoovah’s Xnode Editor, Add LabVIEW INI Key: XNodeWizardMode=TRUE

• Activation: Node on Block Diagram

• Uses: Creating new Node Types

• Example: A few on LAVA

• Learn More: https://labviewwiki.org/wiki/XNodes

XNode XXXXX



• Pre and Post Build Actions
• LabVIEW.INI Keys
• LabVIEW Callback VIs
• External Editor (Think Statechart Module) 
• Tag Get/Set
• Package Managers

Others
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